Exibição de número pela função Cut()

Prezadxs, olá!

Estou com uma dúvida em relação ao output da função “Cut”. Estou usando ela para criar categorias dentro dos meus dados e funciona muito bem. Meu problema é que o resultado dela está vindo em notação científica (por que minhas categorias são de mil em mil).

Alguém sabe como eu poderia fazer para o resultado sair com o número inteiro?
Exemplo: [3e+03,4e+03] = [3000, 4000]

Na tabela não vi muito problema em deixar assim, mas depois precisei plotar e não consegui arrumar isso.

Segue exemplo reprodutível:

# Carregar pipe
library(magrittr, include.only = "%>%")
#> Warning: package 'magrittr' was built under R version 4.0.3

# Carregar base de exemplo
diamonds <- ggplot2::diamonds

# Gerar coluna de exemplo
diamonds %>% 
    dplyr::mutate(price = price*10) %>% 
    dplyr::mutate(categoria_price = cut(price, c(0,
                                                 1000,
                                                 2000,
                                                 3000,
                                                 4000,
                                                 5000,
                                                 6000))) %>% 
    dplyr::select(categoria_price)
#> # A tibble: 53,940 x 1
#>    categoria_price
#>    <fct>          
#>  1 (3e+03,4e+03]  
#>  2 (3e+03,4e+03]  
#>  3 (3e+03,4e+03]  
#>  4 (3e+03,4e+03]  
#>  5 (3e+03,4e+03]  
#>  6 (3e+03,4e+03]  
#>  7 (3e+03,4e+03]  
#>  8 (3e+03,4e+03]  
#>  9 (3e+03,4e+03]  
#> 10 (3e+03,4e+03]  
#> # ... with 53,930 more rows

Created on 2021-05-11 by the reprex package (v2.0.0)

Muito obrigado pela atenção!

Abraços.

tem um parâmetro chamado dig.lab que controla isso!

cut(x = c(12, 123, 1234), breaks = c(0, 1000, 2000, 10000), dig.lab = 4)

[1] (0,1000] (0,1000] (1000,2000]
Levels: (0,1000] (1000,2000] (2000,1e+04]

Se vc colocar 4, ele deixa até 4 digitos. Daí se tiver mais que 4, ele volta a colocar como notação científica.

1 Curtida

Que show! Era bem mais simples do que pensei.

Muito obrigado, Athos!

1 Curtida

Para desabilitar notação científica escrevo antes do script “options(scipen = 999)”.

Olá, Mário.
Obrigado pela dica. Eu faço o mesmo nas minhas análises hahahaa, infelizmente com o cut() aqui não funcionou, ai tive que buscar ajuda dos mestres :smile: