Problemas com instalação do Keras no Rstudio Cloud

Estou tentando instalar o keras no Rstudio Cloud, mas não consigo finalizar a instalação do tensorflow. Quando executo install_tensorflow(), obtenho o seguinte erro:

Killed
Error: Error installing package(s): ‘tensorflow==2.4’

Segue o print do Rstudio Cloud.

Captura de Tela 2021-05-22 às 15.03.41

Alguém já teve esse erro ou tem alguma sugestão de como resolver, por favor?

1 Curtida

Oi Angélica! Eu nunca usei o tensorflow mas tentei reproduzir o seu erro e tive o mesmo resultado (Erro ao instalar o tensorflow versão 2.4).

Pesquisando no google achei isso: Trouble setting up tensorflow on RStudio Cloud

Tentei a resolução que encontraram e não gerou erro, mas a forma que resolveram foi usando uma versão anterior do tensorflow, como argumento version (não sei se isso pode afetar o seu uso… @dfalbel ?)

Esse é o código que indica para instalar a versão 2.0.0, e não gerou erro quando eu testei:

install.packages("tensorflow")
tensorflow::install_tensorflow(version = "2.0.0")
1 Curtida

Eu tenho a impressão de que o TensorFlow é maior do que o espaço que você pode usar no RStudio Cloud, porque por padrão ele instala uma versão com suporte para GPU’s. E é porque é muito grande que o RStudio Cloud mata o processo.

Eu tentaria instalar a versão ‘somente cpu’, usando algo assim:

tensorflow::install_tensorflow(version="cpu")
2 Curtidas

Muito obrigada pela resposta, Bea e Dani! Funcionou aqui :slight_smile:

1 Curtida